1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VR support for Entropia may come sooner than you think (unofficially)

Discussion in 'General Entropia Universe Discussion' started by Wistrel, Mar 27, 2018.

  1. Wistrel

    Wistrel Kick Ass Elf

    I've just been checking out MTBS3D again to see if there is any update on the Vireio Perception 4 project. The developer has been posting in February to say it is getting there and they are hoping to do an initial release of alpha 4 this quarter.

    I suspect this might be an Elon Musk style deadline but it's good to know things are progressing and that the project didn't die.

    When it comes out I'll give it a try and report back.


  2. columbo.
    • Like Like x 1
    • Funny Funny x 1
  3. Wistrel

    Wistrel Kick Ass Elf

    Well no updates on Vireo but I did manage to finally get the Rift working again after Oculus borked it the other month (I may have to ask them where my £15 store credit is that they offered as compensation). Because I'm smack in no mans uppsuported land I had to do a complete reinstall using the beta drivers from reddit. The official patch had the annoying CPU check in and my CPU is "allegedly" too old so yeh, back to the start.

    Thankfully all worked again and I was able to do some stuff I've been meaning to try like the Leap Motion scaffold for block placing experiment. This was cool but alas my PC really struggles to do VR and hand tracking at the same time. I'll be damned if I have to upgrade though before the final generation of PCs come out - I'm just praying they'll still support windows 7 >_<.

    Other thing I finally managed to get working was hand tracking in steam VR as alternative to Vive controllers (seems there is something up with the driver install and you have to move some files around and edit a steam config file before it goes). Alas, again my PC can't really handle it. It can just about cope with 1 hand, but 2 just causes VR to spaz out. A nice experiment but not gonna be useful without an upgrade.

    Finally tried out some free demo called Aircar. This was really nice. You fly around a bladerunner esque city in the rain. The rain on the windows was superb and it had a great cockpit. Had that "I want to reach out and touch the glass" thing but of course, we didn't get that sort of tech yet.

    I've still not tried the driver switcher I'd need working before I can use existing versions of Vireo or old Rift demos again. Maaaaybe... I'll try tomorrow... dunno. Feel a bit VR'd out for one weekend now.

    Still, nice to have it back working again.

    • Like Like x 2
  4. Aircar demo:

    Looks cool. I only have cheap VR headset that uses a mobile phone. I think this is Oculus only?

    Will have a search later.
  5. Wistrel

    Wistrel Kick Ass Elf

    Haha actually I found that one yesterday and indeed it was very nice! Something that might be of interest is that I've tried 2 Cryengine VR demos today called Back to Dinosaur Island (2) which were pretty darn awesome. There was something slightly swimmy about the side to side movement but other than that they were pretty visually stunning. Only downside was that they were too short. Especially the 2nd one which presented this massive area to explore then keeps you on a rail. Damn you Crytek, you show me crashed spaceships and don't let me explore them!

    Anyhow those two demos were actually SDK 0.8 only compatible but I found this wrapper that made 0.8 work with the CV1 drivers. This said, that was the only thing the wrapper did appear to work with. It is meant to support 0.6 too but I've not had any luck getting anything to notice it... maybe the stuff I have is 0.5.

    Back to Vireo and Entropia, the 3.0.1 version of Perception uses the 0.8 Oculus SDK but alas I just get an error on load when I try things with the wrapper. The older versions of perception, actually I am not sure what version of the SDK they use but, despite injecting and doing the usual warping/split screening they didn't work as the Rift wasn't detected.

    I've just tried the runtime switcher (just a small trial with the 0.8SDK) but it basically broke everything. Neigher the 0.8 or CV1 drivers worked. 0.8 said no rift and CV1 said no service. In short it fsked it. Thankfully I'd taken a restore point so all was well after a quick roll back.

    In conclusion, unless the wrapper is improved I'll be waiting for vireo 4 or MA before trying Entropia in VR again. Ah well...

  6. Wistrel

    Wistrel Kick Ass Elf

    Just checked not much in the way of updates. Programmer has worked on it a bit this year I can see but nothing since September. There are some video interviews on the site about some stuff. Fustrated people on forums understandably.
  7. Why? such a short time? I still cannot ly down in Entropia since 2009.
    • Funny Funny x 1
  8. Wistrel

    Wistrel Kick Ass Elf

    They are only mildly fustrated. I think its because the older version is sorta lacking behind the hardware development now so tricky to use. It's kinda gone a bit the way of all those original games/demos people make for DK1 or DK2 which are kinda lost to the midst of time now.
  9. Jamira

    Jamira Samurai Girl

    My knowledge of VR is really limited. At the other hand we have a saying: I can't lay an egg, but I can smell a foul egg. Bethesda delivered Skyrim VR. It's kinda 1:1. First person even. They didn't change anything. And it's running. They took the already existing world of Skyrim and transfered it to VR. With all the errors you can only see in VR. And? It's amazing! It is still one of a very few running epic games in VR. Simple transformed? Dunno. Ubisoft hesitates to bring Assassins Creed Origin to VR ... Why, if it's so easy, as Bethesda proved?

    Ofc MindArk doesn't have resources like Bethesda and Ubisoft. But knowing that, they shouldn't be such loudmouthes ...
    Last edited: Dec 12, 2018
  10. Tass

    Tass Administrator

    Mh, Bethesda/ZeniMax was on this for a long time already, longer than Oculus even. Actually, Oculus only became a thing because Carmack added Zenimax owned code to Palmer Luckey's glued together electronic scrap. See also: https://en.wikipedia.org/wiki/ZeniMax_v._Oculus
  11. Wistrel

    Wistrel Kick Ass Elf

    To be fair... what the Vireo guy is doing is fairly epic. Fairly high on the major league hacking scale to my mind. Trying to create a user friendly product that can easily be configured to hijack any dx9 game and make it work (properly with actual 3d I mean) in VR is... well you make your own judgement.

Share This Page