1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I can't get into the game because EU

Discussion in 'Entropia Community' started by PeterCal, Nov 16, 2016.

  1. My Gold Card device got error 72 which means I need a new one.
    I open today the third support ticket about a simple problem they could have solved but they haven't ....
    Oh they sent me an new Gold Card without the device(the reader)...useless.
    But this month they sent me also an email about new EULA rules about account inactivity, how strange.
    The only solution I was offered after posting the first support ticket was to get an app on my smart phone instead of security card.
    I answer that I don't have an smartphone and not planing to have one.
    after that they ignored me so Open a second support case and they sent me a new Gold card instead of a new card reader.
    I don't see how this can be a better security for my account than a card reader and a Gold card?!?!

    I'm speechless I think they want to wipe my account(in which I deposited a lot) or something otherwise I don't see why they doing it...
     
  2. Have you changed the batteries?
     
  3. San

    San

    The same 2 posts by the same 2 avatars are repeated here verbatim. They already receive answers from the larger community over there.
     
  4. RAZER

    RAZER Custom title ... uh ...

    take it apart, clean the contacts and change bateries, that usually helps for me
     
    • Winner Winner x 1
  5. What he said
     
  6. Sionkiewicz

    Sionkiewicz One of those Americans

    Contact support, send them your ID, drop the gold card from your account..

    Problem solved..
     
  7. dalewj

    dalewj StoryTeller/Nerd/Gamer

    i tried to drop my gold card from my account 4 months ago. Just to get in between games and check out the new planets..... 4 months ago......
     
  8. Sionkiewicz

    Sionkiewicz One of those Americans

    Net sure what to tell you.. have seen it get done in as fast a 2-3 days.
     

Share This Page